• Friday , 20 October 2017

PHP Series – Building A PHP MySQL Forum Tutorial Series Part 2 – Displaying Forum Categories

Code Canyon



Follow me on Twitter @ http://twitter.com/tktutorials Check out my website @ http://www.timkipptutorials.com This is part two of this tutorial series. In part two we …

Original source

3d Ocean

Related Posts

36 Comments

  1. The Definitionist
    September 23, 2017 at 18:44

    Even after 6 years and that mysql is deprecated it is still the best forum tut far and wide. Thx for that. BTW, your website seems down to me. Are you at GitHub by chance?

  2. 红月亮
    September 23, 2017 at 18:44

    This is a really good tutorial!

  3. dasfsdf sdfsdfdsf
    September 23, 2017 at 18:44

    It says "Warning : mysql_query() expects parameter 1 to be string, object given in C:xampphtdocsForumindex.php on line 33

  4. Deathwish RSPS
    September 23, 2017 at 18:44

    Notice: Array to string conversion on line 38 where i try to echo the category title and description

  5. Joshua Rasalan
    September 23, 2017 at 18:44

    hi only one category shows up even though i already made 2 categories

  6. Promoting Sounds
    September 23, 2017 at 18:44

    Hi, it says 'no database selected' when i load the page?? ive checked the code over and over i dont think its wrong

  7. 石忠和
    September 23, 2017 at 18:44

    This tutorial is really excellent and helpful ,your teaching in the video is really clear. Thank you !

  8. DarkparatroopaMC
    September 23, 2017 at 18:44

    Hi, when the categories are displayed for me, they seem to appear twice…

  9. chaddy brad
    September 23, 2017 at 18:44

    In my webpage I am getting the error message – Can't connect to MySQL server on 'localhost' (10061). Why is this? Any advice would be appreciated, thanks!

  10. TimKippTutorials
    September 23, 2017 at 18:44

    Cool. I totally looked over that line. You set a limit to only retrieve a certain number of rows from a database table. That way if you had 1000s of rows you could limit to only showing 10 or whatever at a time.

  11. TimKippTutorials
    September 23, 2017 at 18:44

    The problem is how you are using MySQLi. Read the PHP documentation about how to properly use MySQLi. If you want a quick fix, you can use MySQL instead by just removing the "i" from MySQLi and removing $con, from you queries.

  12. Anthony Greene
    September 23, 2017 at 18:44

    Hey thanks very much! I completely looked over the .= to append. Thank you very much this tut was the best thing I've found so far and exactly what I needed for my project!

  13. TimKippTutorials
    September 23, 2017 at 18:44

    Without seeing the code my guess is that either you have a LIMIT on your query or within your loop you forgot to use ".=" instead of just "=" to add each value to display.

  14. Anthony Greene
    September 23, 2017 at 18:44

    Hey man great vid!
    I am having a problem, after I made the two different forums by inserting them manually it will only show me the last one added. I have tried changing the sort but to no avail. What am I doing wrong?

  15. TimKippTutorials
    September 23, 2017 at 18:44

    WOO!! 🙂

  16. TimKippTutorials
    September 23, 2017 at 18:44

    thank you for the input. I will try and explain more in upcoming tutorials.

  17. TimKippTutorials
    September 23, 2017 at 18:44

    I am intending to do more updated tutorials in the near future that maybe have that feature.

  18. TimKippTutorials
    September 23, 2017 at 18:44

    Thank you!

  19. TimKippTutorials
    September 23, 2017 at 18:44

    Thanks!

  20. TimKippTutorials
    September 23, 2017 at 18:44

    Thank you for your support!

  21. mike k
    September 23, 2017 at 18:44

    Tim, your awesome!! … good talk.

  22. OtaconAlonsus
    September 23, 2017 at 18:44

    I like these tutorials. They are very clear and concise – straight to the point.

  23. MrFireVirus
    September 23, 2017 at 18:44

    thanks, you should have add parents for the catagories. first of al that would complete the tutorial. and i need that, but i can probaly figure that out my self.

  24. tlchounramany
    September 23, 2017 at 18:44

    After I add the reply to a topic, I get this "This topic does not exist.". Also how do you update the reply after adding a reply to the topic? Thanks

  25. Isaiah Robinson
    September 23, 2017 at 18:44

    Never mind I missed the period in front of the equal sign on line 40

  26. Isaiah Robinson
    September 23, 2017 at 18:44

    I only get one category entry and I have the same exact code, what could be the problem?

  27. JOTTABYTE
    September 23, 2017 at 18:44

    Thanks very very much for this, you are my hero.

  28. Anthony Lusher
    September 23, 2017 at 18:44

    Woooooord! Very clean code.

  29. Vytautas Paliokas
    September 23, 2017 at 18:44

    Hello.Very good totorial. But there is a problem. Forums do not count many replies it is. Maybe in topics table should be (topic replies)? I do not know. Can you help me Timki?

  30. TimKippTutorials
    September 23, 2017 at 18:44

    I see that you have posted a topic in the forums. I will provide more help there. Please post your code there though so we can see where the problem is. Thanks.

  31. TimKippTutorials
    September 23, 2017 at 18:44

    @humanoPR There might be a problem in your sql statement.

  32. WaterikXPRX
    September 23, 2017 at 18:44

    I have a problem to is that I get only the last category and added

  33. TimKippTutorials
    September 23, 2017 at 18:44

    @jago125 I'm glad you found this tutorial helpful. If you have any questions or everything, feel free to check out my site

  34. TimKippTutorials
    September 23, 2017 at 18:44

    @dhrjani2 Thanks!

  35. TimKippTutorials
    September 23, 2017 at 18:44

    @frisksten Thanks! I'm glad they are helping you out.

  36. Dhruv Jani
    September 23, 2017 at 18:44

    awesome work man …

Leave A Comment

You must be logged in to post a comment.